Cannot delete items in trash


If i select messages in my trash, whether it be multiple messages or one at a time, the messages do not actually delete. They stay there. I have to go to RB6 to actually delete anything.

Running FF56 x64


I am seeing the same issue regardless if I check several items and hit delete, or by drag and drop method.

This should be fixed now. Can you confirm that?

I confirm my observation posted in another thread: no, still not fixed. Individual messages are not deleted from Trash.

I confirm as well… not fixed… I tried both Chrome and FF56

We’re taking another look at this, thanks!

  • Geir


Do you have any idea when this will be implemented?

Right now, I have two Trash folders in my IMAP account:

  1. Root->Trash (this is the “official” trash folder)
  2. Root->Inbox->Trash (I have no idea as to why it was created, I just realized a couple of weeks ago that I had over 4,000 deleted emails there :blush:) - maybe some email tool I used decided to create it.

Using the new web interface, whenever I try to delete a message in 1), the message just stays there. Thus said, there is no way to either empty the Trash folder, either individually or as whole using the new interface, right?

Hi there,

We have an existing issue (#795) for permanently deleting messages from Trash and I’ve bumped this with our developers now.

If you see a Trash folder anywhere else than at the root level it’s likely that it was created by an IMAP email client/app at some point, and that it’s moving messages there instead of the standard Trash folder.

If you’re using such a program/app you might want to check that your IMAP settings are correct as per, and specifically that it’s set to move messages to Trash when deleted.

– Geir