Deleting problems

#1

I have not used the webmail 7 for a while. I tend to use the old interface for a number of reasons. While there have been big steps taken lately to improve the experience, there is just something about the whole interface that i really do not like.

That aside, i just logged in today for the first time in over a month. I have issues with deleting things. I select my items and hit the trash can. If i only select 2-3 items, there is about a 2 second or so delay from the time i hit the trash can to the time the items disappear from the list. When i selected about 30 items and hit the trash can, everything deselected, about half of the items were removed. I thought at that point something buggered up and i came to select the balance of the emails again, when then they too disappeared. I would say about 5-7 seconds for the entire 30 items to be removed from the list.

Why is there such a delay?

Also, not sure if i need a different topic for this as it is also sort of related…

  • There is still no option to empty the trash.

  • If i select the select button on to which i guess means select all, it highlights everything on the screen except the last item on the bottom. I then have to page down and repeat the process. However, that last line that will not auto select will not allow me to manually click on it either. No matter what i do. I have to scroll up slightly to be able to select it. But that does not work when it is the last email in the folder. I have to delete everything else first, then select that one last email and delete that one. This issue is not limited to only the trash folder. This problem happens on any folder i happen to be in.

  • I know i can click one selection square and drag down to highlight multiple ones. That only works for the items showing on the screen. I would then have to page down and repeat the process. However, if my mouse wanders beyond the 1cm (or so) column width, the mouse automatically selects the change the column width (i see the little icon for changing width) and it stops selecting. So if i am not paying attention to going down in a perfect straight line, my selection stops and have to start all over from where my mouse wandered.

I am currently using FF56.02 64bit on Windows 7 Pro.

1 Like
#2

Hello Nathaniel,

Thanks for your mess here, and for taking the time to give us this detail. We’ll try some of the message operations you mention in a test account and see if we can replicate the problem. We are still adding features to the interface, so emptying the trash should be along soon.

#3

I agree, I find myself using the old interface out of preference. I find the new interface slow (especially from Canada) and I also find it not as quick/clean as the current interface. Just wanted to add my $0.02 to this.

1 Like
#4

I just love the preview part of RB 7 and when tidying up email it is really useful as i can look at each message quickly. It is a great job. However I did find today that messages were not deleting so I ended up going back to the the old interface for this part.

#5

@kenfran Could you give a bit more detail on what happened when you tried to delete messages please? What did you see? Did the message disappear and come back, or did you just get no result when you clicked to delete them? Were you using the icon in the message preview to delete the message, or the one in the floating toolbar on the right? Sorry for all the questions, but it helps us identify where the problem might be.

#6

Hi Dave,

I have gone in to retry, In the section without a preview page but floating toolbar I have got some messages that delete after a lag after but others just don’t delete. If I press delete a second time the checkbox unchecks? Hope this makes sense. It has also frozen after a few attempts so I have closed out of browser to get back in.

The preview section seems to work better now with a slight lag.

Hope this is of same help

#7

Has there been any update on some of the deleting issues that were mentioned in my original post?

Today I tried again and i am still having most of the same issues…

1- clicking the select all icon selects everything visible on the screen except the last item. I have to scroll to the next screen keeping that item visible and then clicking the select all button again to get it. Then on that new screen, the last item is not selected. When i get to the bottom of the list, nothing will allow me to select that last item. Whether clicking the select all or manually clicking it. I have to delete the emails at this point and then click on that last item manually to delete it.

2- related to #1, i had finally selected 70 emails to delete. I clicked the trash can and and i saw a little black popup on the bottom come up saying deleting 1 of 70. Then it would flicker as the number would increase. I think the whole process took about 10 seconds before the messages disappeared. Then i had another 3-4 seconds before my folder would display whatever emails had chosen not to delete. This whole process just seemed to take forever. on RB6 the minute i click delete it is all gone and whatever is left is instantly displayed. I am not sure why it has to take so long for the process to take place.

Also having the same issue when dragging down the list of emails. If my mouse wanders slightly off the column it automatically switches from selecting the emails to selecting the column width icon and i have to unclick and start over again.

#8

I was wondering if there has been any movement on this. I am still having this issue. Nothing i do will allow me to select the last email in the list. Even manually clicking it. I have to delete all other emails, leaving that last one as the only email left, then i can select it and it will be deleted.

Again, this issue has been dragging on for a log time now.

I am using FF 66.0.4 x64. The problem happens both at work and at home.

#9

I have just tried deleting the same collection of mails twice, once from the search results and once directly from the inbox display. Nothing happens. Here is an extract from the Web Console:

#10

that error code is from the Xapian webassembly module (the local search index). Runbox7 keeps a copy of the search-index stored on your device. Now there’s not enough information there to see what’s actually crashing, so as a quick fix you may try to delete the local search index by clicking the “Stop synchronizing” button in the left menu.

In the “non-synchronizing” view, what you see is the servers version of the message lists, and probably you see your messages are deleted from the server.

If you restart synchronizing again after, you’ll get a new copy of the server version of the search index.

If it is still not able to delete from the local search index. It’s possible to ask Runbox support to re-create the server side search index.