Moving lots of spam to trash gives 414 "Request-URI too large"

I have over 1000 messages in my spam folder. When I click “Move all to trash”, I get a 414 “Request-URI too large” in my browser’s dev tools. This is an obvious bug; the message IDs should not all be part of a DELETE request URL as it will indeed grow to be far too large, they should be in the body of the request. Could you guys please fix this? Otherwise I have to move them 25 at a time!

Hello @jeremy.morton and thanks for your message – and apologies for the belated reply.

We have created this issue on Github to track progress towards a resolution:

In the meantime, a workaround could be to select all the messages in the Spam folder (by first clicking and holding the check-all box at the top of the list to see the option “All rows” and then clicking the check-all box normally) and clicking to move the messages to Trash using the message actions menu.

– Geir