Runbox 7 cookie issues

First a brief note that Runbox 7 has to have the cookie active between browser sessions in order for users settings to be saved. If you find that you settings are not being saved between browser sessions, ie after you have closed your browser and then openned it again it is almost certainly a cookie problem.

It’s easy to test. Open Runbox 7 webmail and make changes to the settings. Logout of Runbox 7, but do not close your browser. Now log back into Runbox 7 and check that you settings have been saved - they should have been. Now logout of Runbox 7 again and this time close your browser. Restart your browser and then login to Runbox 7. If you settings have no longer been saved then you have a cookie problem.

It is not my intention to solve peoples cookie problems. Some people have a natural aversion to cookies - I do, but I also know that some cookies are necessary. So if you have setup you browser to delete all cookies when the the browser closes, then you are going to have this problem.

I hope that anyone who has an opinion of cookies or how runbox uses cookies or any other issues with the runbox cookie will post to this topic.

1 Like

Workaround for Firefox with customized cookie settings

Only relevant to Firefox users who use customised security settings and do not want to use the default Runbox 7 Layout.

If you use Firefox with a lot of custom security settings and in particular have “Delete cookies and site data when Firefox is closed” checked, then you may find Runbox 7 does not remember the settings once you have logged out even when you have added the cookie “” to your exemption list of cookies to Allow and you can see the cookie is being saved between sessions, ie when you close Firefox and reopen.

From “Cookies and Site Data”

  1. uncheck “Delete cookies and site data when Firefox is closed”.
  2. Choose “Clear Data” and clear all the data out.
  3. If you have already added cookie to the exception list then go into “Manage permissions” and remove

From “Content Blocking”
4) Change the level to “Standard” if it is not already set.

  1. Close Firefox and restart.

  2. Start Runbox 7 and set it up the way you want it as default. Then close Runbox 7 but not your browser.

  3. Reset “Delete cookies and site data when Firefox is closed” and add to list of cookies to Allow.

  4. Reset any other security settings as they were originally.

  5. Close Firefox and restart.

Please not some of the above may be unnecessary but I have neither the time or necessity to refine the instruction.

Firefox workaround addendum

Steps (3) and (4) above are not necessary.
Also you may have to uncheck “Keep preview pan open”, available by clicking on the vertical row of 3 dots. Not sure about this - anyone want to verify?

Thanks for posting this on the forum @JohnTowler. I am sure it will be useful to a number of Runbox customers.

Cookie fix periodically stops working

The above cookie fix stops working every so often and my customer RB7 custom display settings no longer work. It can be fixed by just going over the previous procedure I proposed. It seems to go wrong when the box asking if I wanted to synchronise is displayed at startup, I currently do not use indexing. Someone might want to check this out.