Runbox aliases - reply-to set to wrong address

I’m having an issue with Runbox aliases. I have set up mail folders with rules so composing emails in different folders will use different aliases, and incoming mail is also filtered by alias.

However, if I send a second message in an email chain (ie, I send a message, get a reply, then reply back), that reply back comes through to my default inbox. It seems that the “reply-to” gets reset to my main runbox email address, on that reply back that I make.

Is this a known issue?

Hello. This sounds like the reply-to address has been set when it doesn’t need to be. If you click on the Inbox and then Preferences (in Runbox 6) you may see your default address has been entered in the reply-to field. If you remove this and then click Save Settings at the bottom of the page this should resolve the issue. Aliases will use any reply-to set on the Inbox, but if the reply-to is the same as the From address then it isn’t required to have the reply-to set at all.

I hope that helps.

1 Like

Hi Dave,

Thanks for the reply - I did have “reply-to” set for each of my folders, but they were set to the appropriate alias for that folder. I’ll remove those values, as they are not needed, but will this fix my original issue? I did also have “reply-to” set on my main Inbox, to my main email address. However, I had not ticked “same as Inbox” for any of the sub folders.



Hi Andy,

It’s the preferences on the Inbox that are the issue with aliases. However, if you were setting preferences on folders and selecting a profile rather than an alias from the compose drop-down box then it should work as expected. If you are still having problems I suggest you open a support ticket so that we can look at your account settings from this end. Thank you.

1 Like

Hi Dave,

Gotcha, thanks. I ended up removing all “reply-to” settings (Inbox + subfolders), but it sounds like this will still do what I want.

The wierd thing was that the problem would only occur on my second email in a chain - eg, I would compose and send an email from a sub-folder, the reply would come back to the right place, I would reply to that email and send it, and then it would come back to my main Inbox (with reply-to set to my main address).

I was never too sure what a “Proflie” is - from what you say, it’s created when I set custom rules for a subfolder.

Thanks for your help. it looks like my issue has been resolved.

Yes, it sounds like on the first reply it goes to the correct address because the message was sent using a Profile (i.e. preferences based on a folder). However, when you reply again it must be using an alias and then the preference is taken from the Inbox.

The reason it was set up with aliases and profiles is somewhat historical from the earlier days of Runbox but as email usage changed it was clear this was going to get complicated. Therefore in Runbox 7 we switched to Identities and when you reply there Runbox 7 looks to see what address the message was sent to and tries to reply with the correct Identity.

Yes, as you say Profiles are the preferences for a folder, but an alias always uses the Inbox preferences. This is why we list them separately in the Compose drop down menu.

1 Like